Download EMG 7.1.7 Print
Tuesday, 10 January 2017

To obtain username and password for downloads and 30-day evaluation license, use our license request form.

Installing EMG 7.1 and EMG Portal 3 on CentOS 7 »

EMG 7.1 requires a new license key when upgrading from EMG 6 or earlier.

EMG 7.1 is backward compatible with configurations for earlier versions of EMG. It is possible to download the binaries-only distribution and replace the binaries for an earlier version. However, if you need new files in the distribution such as SQL files etc you would need to download the full distribution.

More information about installing binaries only »

EMG 7.1.7 - Overview

To understand the major new functionality in EMG 7.1, please check out the documentation What's new in EMG 7.1.

Changes below marked with an asterisk, "*", includes a fix for a problem which potentially could cause the server to stop unexpectedly.

  • Post delivery reports back for all parts of a merged message
  • Added SNI support for outgoing SSL connections
  • Custom connectors can now parse GSM 03.40 tpdus
  • New connector keyword: GSMNOSCA_IN to indicate no SCA in received GSM pdus
  • New connector keyword: DLL_IGNORE_TRANSPORT_STATUS to force continuation in custom http connectors even on non-200 http status
  • MongoDB: Improved error handling
  • HTTP: Do not add "?" before query string if already present
  • DLR: DLR status could incorrectly be set to 0 when dlr expired
  • Allow setting udh from perl urlhandler
  • Allow setting options 900-999 from perl urlhandler
  • New plugin hook "before_dlr"
  • Improved error handling for INHERIT keyword
  • Log missing failover connector as warning
  • Eliminated potential memory leak when saving of message failde
Important notice 1! When upgrading from an earlier EMG release and using a database a schema change will need to be applied ("emgd --upgradedb"). This schema upgrade may take a long time to complete.
Important notice 2! EMG 7.0 includes functionality that depends on embedded perl. EMG 5.2.6 and later includes Perl 5.12.2 statically linked into the emgd binary. This means that for Perl plugins that do not depend on external modules (such as CPAN modules) there are no external dependencies. Read more »

EMG 7.1.7.48300 - Binaries-only

Downloads are password-protected. To obtain the username and password required for download, please use our license request form.

With SSL/encryption support

EMG 7.1.7.48300, Linux (x86, 64-bit), 12 MB

Without SSL/encryption support

EMG 7.1.7.48300, Linux (x86, 64-bit), 12 MB

Linux versions are built on CentOS 5.4 (64-bit) with glibc 2.12.1.

EMG 7.1.7.48300 - Full distribution

Downloads are password-protected. To obtain the username and password required for download, please use our license request form.

With SSL/encryption support

EMG 7.1.7.48300, Linux (x86, 64-bit), 12 MB

Without SSL/encryption support

EMG 7.1.7.48300, Linux (x86, 64-bit), 12 MB

Linux versions are built on CentOS 5.4 (64-bit) with glibc 2.12.1.